Project

General

Profile

« Previous | Next » 

Revision 9074

*{.sh,run}: removed extra space between function name and (), which is apparently not needed even though `help function` includes it. this greatly improves readability, including when function names are pasted into commit messages!

View differences:

util.run
8 8
. "$(dirname "${BASH_SOURCE[0]}")"/path/to/util.run or file_including_util.run
9 9
. "$(dirname "${BASH_SOURCE[0]}")"/other_includes
10 10

  
11
cmd ()
11
cmd()
12 12
{
13 13
	echo_func
14 14
	"$(dirname "${BASH_SOURCE[0]}")"/path_relative_to_self
......
23 23

  
24 24
# users can override run_args_cmd to perform other commands (or no commands)
25 25
# after the script is read
26
on_exit () { run_args_cmd; }
26
on_exit() { run_args_cmd; }
27 27
trap on_exit EXIT
28 28

  
29 29
top_file="${top_script%.run}"

Also available in: Unified diff