Revision 9074
Added by Aaron Marcuse-Kubitza over 11 years ago
archives.sh | ||
---|---|---|
5 | 5 |
|
6 | 6 |
### zip |
7 | 7 |
|
8 |
zip ()
|
|
8 |
zip() |
|
9 | 9 |
{ |
10 | 10 |
stdout2stderr=1 try limit_stderr_cmd self "$@" |
11 | 11 |
ignore 12 # "zip has nothing to do" (`man zip`) |
12 | 12 |
end_try |
13 | 13 |
} |
14 | 14 |
|
15 |
unzip () { stdout2stderr=1 limit_stderr_cmd self "$@"; }
|
|
15 |
unzip() { stdout2stderr=1 limit_stderr_cmd self "$@"; } |
|
16 | 16 |
|
17 | 17 |
set_inv force |
18 | 18 |
alias zip_newer='zip ${no_force:+-u }' |
Also available in: Unified diff
*{.sh,run}: removed extra space between function name and (), which is apparently not needed even though `help function` includes it. this greatly improves readability, including when function names are pasted into commit messages!